Jump to content
krizrox

Playback Option

Recommended Posts

Sorry if I missed it but is there a way to configure SamPro to automatically stop playback at the end of the last object in the VIP? I'm sure there must be, I just haven't found the correct setting. Thanks.

Share this post


Link to post
Share on other sites

Hi, for the latest version = 10.02 you switch off the default 'LOOP mode' in the transport or switch to 'Play Once' on Toolbar2.

Cheers

M

Share this post


Link to post
Share on other sites

Sorry I tried those options and the playback cursor just keeps going on past the last object. I always have to hit the space bar to stop playback. Any other suggestions?

Share this post


Link to post
Share on other sites

You need to highlight the area (click and drag) over the area you want played. Turn off the loop function. It will now play the grayed out area and stop. With the loop function on it will start over.

Jeff

Share this post


Link to post
Share on other sites
You need to highlight the area (click and drag) over the area you want played. Turn off the loop function. It will now play the grayed out area and stop. With the loop function on it will start over.

Jeff

Ahh - ok. Thanks. Seems clunky to me though. In Sonar it stops at the end of the last clip (object) automatically. Why wouldn't that be a default setting anyway? What's the point in letting the playback cursor keep running if there's no more audio in the VIP to be played? Why am I asking myself these questions? I don't know :)

Share this post


Link to post
Share on other sites
You need to highlight the area (click and drag) over the area you want played. Turn off the loop function. It will now play the grayed out area and stop. With the loop function on it will start over.

Jeff

Ahh - ok. Thanks. Seems clunky to me though. In Sonar it stops at the end of the last clip (object) automatically. Why wouldn't that be a default setting anyway? What's the point in letting the playback cursor keep running if there's no more audio in the VIP to be played? Why am I asking myself these questions? I don't know :)

It won't automatically stop unless you pick 'play to end of range', or 'play to last object' (or something like that - not at my machine right now, and I use a hotkey).

Greg

Share this post


Link to post
Share on other sites

Thanks I'll look for those options. I did look and couldn't find them before but I will look again. It's interesting how some of these commands get buried. You'd think it would be there in the Playback menu (maybe it is and I just missed it).

Share this post


Link to post
Share on other sites
Thanks I'll look for those options. I did look and couldn't find them before but I will look again. It's interesting how some of these commands get buried. You'd think it would be there in the Playback menu (maybe it is and I just missed it).

It has an icon - and again, stopping at the end of the last object is not automatic.

try double-clicking outside to the right of the longest object/track, and ctrl+space bar for playback to the end of object (I think).

This is the type of sequence of commands where having Magix consider adding a scripting command for grouping different steps. For example, highlight object/range-to-object/playback to end of range - all with one hotkey.

I think someone mentioned that they are working on a scripting feature (I know about 3rd-party scripting).

Greg

Share this post


Link to post
Share on other sites

Toolbar2 has the play once icon but it doesn't show the chosen state like the borrowed loop button in the transport does. Also Toolbar2 acts as a transport bar.

Share this post


Link to post
Share on other sites

OK thanks for the replies. So if I understand, I have two options: 1) manually press the space bar to stop playback or 2) create a range over the entire project and select play once in order to get it to stop.

Weird. :lol:

If I have to choose between the two options I guess I'll take #1. It seems like less hassle.

Is the reason for this have something to do with trailing effects tails or VSTx instruments playback or MIDI or something?

Share this post


Link to post
Share on other sites
Is the reason for this have something to do with trailing effects tails or VSTx instruments playback or MIDI or something?
Or something. I've known this behaviour since Ver5 and didn't suspect it to be wrong till now. Back then though the project length would grow if you let the cursor go on too long which had to be deleted as extra space.

Cheers

M

Share this post


Link to post
Share on other sites
Is the reason for this have something to do with trailing effects tails or VSTx instruments playback or MIDI or something?
Or something. I've known this behaviour since Ver5 and didn't suspect it to be wrong till now. Back then though the project length would grow if you let the cursor go on too long which had to be deleted as extra space.

Cheers

M

Hmm... that was another thing that confused me. I set a project length to... whatever... and eventually end up with a project length of 30 minutes or something which I have to constantly trim down. Am I understanding that this is a normal function of the program... or maybe a better way to put it... an abbynormal function? :lol:

Share this post


Link to post
Share on other sites

Ok - you really wanted this.

There was an option added to stop playback making the project bigger.

Its in:

"Y / Program / General / Lock VIP size against zoom out"

That should make you happy!

:lol:

Share this post


Link to post
Share on other sites
Ok - you really wanted this.

There was an option added to stop playback making the project bigger.

Its in:

"Y / Program / General / Lock VIP size against zoom out"

That should make you happy!

:lol:

Awesome thanks!

Share this post


Link to post
Share on other sites

I see no option like the one mentioned. Am I not looking in the right place?

Share this post


Link to post
Share on other sites

Difficult to say if you don't tell us.....

You do know the 'Y' key puts you system options I take it.

Share this post


Link to post
Share on other sites

Sorry - my bad. I found it. Thanks again. Getting old...eyesight getting blurry... need more beer :rolleyes:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...