Jump to content
Bren Gun

Notation View

Recommended Posts

Hi. Using the demo, I'm still a bit puzzled about Samplitude's notation view, as this will be a prime motivator to REALLY like the program. Among other things, I'm very much interested in using Samp to score (compose/notate) music with VST instruments, including orchestral stuff. Let me tell you, though, I'm a SONAR user who usually uses Finale's notation for serious scoring and SONAR's for "less intense" (but still serious) notation (and for further audio). The fact that I can see notation, PRV, and MIDI parameter/automation editing in one view is VERY attractive.

It seems that, if I'm not mistaken, in Samp there is this particular view. But I've run into a problem: whenever I select multiple tracks, i.e. the whole score in the arranger view, and go into the MIDI editor, the score part at the top is very small and therefore unreadable (not to mention the whole program slows down a LOT). It is probably a very trivial thing solve, but the Samplitude GUI is not so friendly to me nor intuitive, and my impatience only gets worse when something doesn't work. Even though I like the program, I think I will soon start to hate it just because of this.

Share this post


Link to post
Share on other sites
Hi. Using the demo, I'm still a bit puzzled about Samplitude's notation view, as this will be a prime motivator to REALLY like the program. Among other things, I'm very much interested in using Samp to score (compose/notate) music with VST instruments, including orchestral stuff. Let me tell you, though, I'm a SONAR user who usually uses Finale's notation for serious scoring and SONAR's for "less intense" (but still serious) notation (and for further audio). The fact that I can see notation, PRV, and MIDI parameter/automation editing in one view is VERY attractive.

It seems that, if I'm not mistaken, in Samp there is this particular view. But I've run into a problem: whenever I select multiple tracks, i.e. the whole score in the arranger view, and go into the MIDI editor, the score part at the top is very small and therefore unreadable (not to mention the whole program slows down a LOT). It is probably a very trivial thing solve, but the Samplitude GUI is not so friendly to me nor intuitive, and my impatience only gets worse when something doesn't work. Even though I like the program, I think I will soon start to hate it just because of this.

This sort of bugs me as well, and there has been some discussion re: this on the main forum at some point (the default view when it first opens), but for now you can assign hotkeys to zoom in (or use the defaults), or just drag the bottom edge of the notation window down, or click the various buttons in the upper left to turn certain windows on/off. I think once you have things set the way you want, it should always open that way, so give that a try.

Greg

Share this post


Link to post
Share on other sites

Switch off the automatic score zoom in the MIDI Editor Menu > Score. Then the score display size is not altered by the horizontal view section. I think the Demo version has also a problem remembering the last zoom level for the MIDI Editor, but what should work is that you draw a range over 8 bars or so and then open the MIDI Editor for all selected objects. Then the MIDI Editor view will be matched to the marked range in the VIP, in this case 8 bars which is a good estimate to get a proper score view instantly.

In the MIDI Editor with piano roll and score view both enabled, the score might be scrambled horizontally if your horizontal view section is too large. We still allow such a view because it can offer a good overview (where is which voice active...) , even if you cannot see the score details anymore.

@Greg: you can also get a score-only view (without piano roll) by activating the score page mode.

If you work with Finale, too, you can use the MusicXML score export from samplitude.

If samplitude is slow with larger scores, disable the semi-transparent view option in the system dialog (Y) Design > Color section.

If this doesn't help, split your MIDI-Objects every 50 bars or so to work with smaller segments in the MIDI editor which is faster -- you can still put all objects in the MIDI Editor if needed (e.g. for score printing or MusicXML export).

Greetings,

Frank

Share this post


Link to post
Share on other sites

Thanks for the replies. I will try your suggestions soon.

In the meantime I have another question concerning notation and MIDI in the standard Samplitude version. On the information pages on the main site it says it does have the view we're talking about, but I downloaded the manual and it says only Pro has it. This is clearly a contradiction, so I wonder which is true.

Share this post


Link to post
Share on other sites
Switch off the automatic score zoom in the MIDI Editor Menu > Score. Then the score display size is not altered by the horizontal view section. I think the Demo version has also a problem remembering the last zoom level for the MIDI Editor, but what should work is that you draw a range over 8 bars or so and then open the MIDI Editor for all selected objects. Then the MIDI Editor view will be matched to the marked range in the VIP, in this case 8 bars which is a good estimate to get a proper score view instantly.

In the MIDI Editor with piano roll and score view both enabled, the score might be scrambled horizontally if your horizontal view section is too large. We still allow such a view because it can offer a good overview (where is which voice active...) , even if you cannot see the score details anymore.

@Greg: you can also get a score-only view (without piano roll) by activating the score page mode.

If you work with Finale, too, you can use the MusicXML score export from samplitude.

If samplitude is slow with larger scores, disable the semi-transparent view option in the system dialog (Y) Design > Color section.

If this doesn't help, split your MIDI-Objects every 50 bars or so to work with smaller segments in the MIDI editor which is faster -- you can still put all objects in the MIDI Editor if needed (e.g. for score printing or MusicXML export).

Greetings,

Frank

Frank, I know about page mode, but would just prefer to be able to have the whole song (or long range), see only the notation (no piano roll), and have the zoom behavior be similar to the VIP, when I can zoom in without the staves scrunching up towards the top of the window. The behavior IS different right now.

Is there a way to turn ALL windows off and have ONLY the notation window open?

Is there a way to get the controller window to change to show a chosen track/stave? Currently it does not seem to change when I change instruments in the top pull-down, or when choosing a stave/track.

Otherwise, overall the MIDI editor in Samp. is WAY ahead of other hosts IMO.

Thanks again,

Greg

Share this post


Link to post
Share on other sites

> when I can zoom in without the staves scrunching up towards the top of the window

That should only happen if Score AUTO ZOOM is enabled. Have you switched it off and tried again?

> is there a way to turn ALL windows off and have ONLY the notation window open

You cannot hide the piano roll completely in linear score view mode, but you can of course hide the list and controller view.

> Is there a way to get the controller window to change to show a chosen track/stave?

Activate the "track display filter" (little button besides the track name field on the right). This should do it.

> Otherwise, overall the MIDI editor in Samp. is WAY ahead of other hosts IMO.

Thx, I'm glad you like it :)

Greetings,

Frank

Share this post


Link to post
Share on other sites
> when I can zoom in without the staves scrunching up towards the top of the window

That should only happen if Score AUTO ZOOM is enabled. Have you switched it off and tried again?

> is there a way to turn ALL windows off and have ONLY the notation window open

You cannot hide the piano roll completely in linear score view mode, but you can of course hide the list and controller view.

> Is there a way to get the controller window to change to show a chosen track/stave?

Activate the "track display filter" (little button besides the track name field on the right). This should do it.

> Otherwise, overall the MIDI editor in Samp. is WAY ahead of other hosts IMO.

Thx, I'm glad you like it :)

Greetings,

Frank

yes, it would still be great to be able to have only the notation window open rather than having to slim down the piano roll.

I have auto zoom already turned off. Zoom behavior is the same in either mode.

Track display filter was already turned on. Had to turn it off and back on again to get the channel/track changes to switch in the controller window.

Thanks again,

Greg

Share this post


Link to post
Share on other sites

> I have score auto zoom already turned off. Zoom behavior is the same in either mode.

So if you open a MIDI object in the Score Editor,

1) the note head size resp. staff line distance is changed (set smaller),

2) or is just the horizontal section quite large so that the horizontal distance between the score symbols is scrambled so they visually overlap?

1) would be a bug, 2) is "natural" behaviour.

Share this post


Link to post
Share on other sites
> I have score auto zoom already turned off. Zoom behavior is the same in either mode.

So if you open a MIDI object in the Score Editor,

1) the note head size resp. staff line distance is changed (set smaller),

2) or is just the horizontal section quite large so that the horizontal distance between the score symbols is scrambled so they visually overlap?

1) would be a bug, 2) is "natural" behaviour.

If I have multiple staves and zoom in to fill the (let's say) 8 staves to fill the screen vertically, and then zoom in on one track, the staves 'scrunch' themselves back up against the top of the window.

I DO occasionally get treble/bass clefs overlapping notes and staves in the middle of the tracks.

Also, if you drag the bottom edge of the score window - to reduce the piano roll window (that you can't turn off), zoom in/out, etc., close the MIDI editor, and when reopening, the piano roll is back up to where it was. In other words I don't think the various window positions and/or zoom levels are retained during the session.

You can test by opening a multi-track, multi-stave song, drag the bottom edge of the window down (to reduce the piano roll window that can't be turned off :) ), zoom in one one track both vertically and horizontally, and see what happens.

Greg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...