Jump to content

What Is With This Retarted Behaviour?


poofox
 Share

Recommended Posts

who's retarded, me or whoever schemed this business? i'm listening to recorded drum tracks, trying to cut and delete the crap and saving some of the better sections to loop. i assigned scroll lock to the 'f' key to make this simpler on myself. (i can hit it to stop scrolling and make a cut and then hit again to catch up to the cursor.) ok my first wtf award goes to the object property which makes it impossible to drag the right end of an object after splitting it. in fact even though i can drag the left end of the new right side object, pulling it to the right doesnt even separate the objects, as i would reasonably expect. to do that i have to drag that over and then, and only then, the right side of the left object can i move, thereby separating the two split objects. is this some purposeful nonsense designed to make a simple edit a tedious chore? i dont understand and pray there is a hidden option somewhere to turn it off.

but even more irritating is the mousewheel behaviour. for instance, im listening, but want to move my screen back a little bit for something that i just heard. so i have the mousewheel set to scroll horizontally, but the moment i touch it, suddenly im back at the point from which i started playing, and now have no idea where that spot was i just wanted to examine. why the hell is it designed that way? not to mention that i have to hit that scroll lock key four times after i manually scroll to get the autoscroll going again. i cant think of a single advantage to that!! and then theres the zoom, which also uncannily acts exactly opposite from the way in which it would be useful. if i click off the scroll lock and can somehow manage to get back to where i wanted to be, using the mousewheel to zoom in for a closer look shoots my screen back to wherever the scrolling playcursor is. um, well if i have the option to turn the scrolling screen off, what good does that do me if its going to shoot off to wherever the poo it wants at the most inconvenient of times?!?!

please samplitude gurus, help me make it stop!!! tell me samplitude really is the one!!!

Link to comment
Share on other sites

ok despite my bitching, i managed to find a better workflow.... without that nasty scroll lock behavior. anyways, ill just quickly share what ive found. i switched the button that was formerly known as scroll lock to something about updating section to the play cursor position. so i can just tap that to get where it is and freely scroll around with the mouse wheel. i have shift + wheel set to zoom and ctrl + wheel switching active track. then ive got the cut mouse mode set to c, and object mouse to v, and b to delete, and g to range so i can quickly edit without looking at the keyboard or moving my hands. its quite nice.

but i still have gripes about the object split and resizing behaviour.

and so wish there was a 'locate in empty space' option for the play cursor. now actually the single only thing i miss from cubase...

Link to comment
Share on other sites

ok my first wtf award goes to the object property which makes it impossible to drag the right end of an object after splitting it. in fact even though i can drag the left end of the new right side object, pulling it to the right doesnt even separate the objects, as i would reasonably expect. to do that i have to drag that over and then, and only then, the right side of the left object can i move, thereby separating the two split objects. is this some purposeful nonsense designed to make a simple edit a tedious chore? i dont understand and pray there is a hidden option somewhere to turn it off.

Yes, there is. :P

When there is a crossfade between the two objects moving the object's edge over moves the entire crossfade while keeping the two tracks together (it won't separate them). This is good if you are trying to edit together two separate objects and want to find the best place to have them crossfade. It would be a pain for them to keep separating every time you tried to move the crossfade point.

To get the functionality that you want, you need to turn off automatic crossfades. This way when you split the object, they won't be crossfaded together and you will be able to do both of the functions you want (separate them and move the right edge of the left object). You can use the icon in the toolbar to disable the automatic crossfades or you can assign it to a keyboard shortcut. This option is called "auto crossfade active" and it's located at the bottom of the Edit menu.

but even more irritating is the mousewheel behaviour. for instance, im listening, but want to move my screen back a little bit for something that i just heard. so i have the mousewheel set to scroll horizontally, but the moment i touch it, suddenly im back at the point from which i started playing, and now have no idea where that spot was i just wanted to examine.

What I found is that it won't jump to another location as long as you don't have one of the play cursors in the window when you zoom (either the cursor where you started playback or the current position). If either one of those are on your screen when you zoom then it will keep the cursor centered in the screen as you zoom.

I posted in the registered section not long ago how much I love Samp zooming to the cursor position (because I'm currently using Logic at school and it doesn't do this and it's been driving me up the wall! ;)) and someone there brought up another instance where this is not desirable (they stretched the VIP window over two monitors and zooming with the cursor in the center of the screen put the cursor in between the two monitors). I mentioned then that locking the center of the screen to the cursor could be added as an option that can be activated/deactivate so that you can use either option and it's worth repeating again. So with any luck it'll be added in one of the menus in the not to distant future.

not to mention that i have to hit that scroll lock key four times after i manually scroll to get the autoscroll going again. i cant think of a single advantage to that!!

I don't think it has anything to do with the scroll lock, once you disable the scroll lock you just have to get the playback cursor inside your screen and then it'll lock onto it and autoscroll will get going again. So if you have the zoom set to the mousewheel also you can zoom out till you see the cursor (or you could scroll over to catch up to it). This behavior actually works without using autoscroll at all. With playback going you can zoom in (and let the playback cursor keep going) and it essentially turns off autoscrolling so you don't loose the position you're in. But simply bringing the playback cursor into view re-enables the autoscrolling. So I think that may be what's happening in your situation.

Hope that helps.

-tkr

Link to comment
Share on other sites

sweet. auto crossfade was the ticket! thanks!!

well this is a long shot but do you know of any way to make the mousewheel zooming more smooth? it works in determined increments, which is too fast and imprecise. especially since my mousewheel is not the 'clicking' kind. then im pretty much good to go....

no wait theres one more thing. ;) when i perform 'remove audio gaps' from the quantizer on a short section that was formerly of a longer section, it adds some long 'wings' of unwanted audio, instead of keeping it the length i chopped it to. how can i avoid this?

thanks for your help

Link to comment
Share on other sites

sweet. auto crossfade was the ticket! thanks!!

You're welcome.

well this is a long shot but do you know of any way to make the mousewheel zooming more smooth? it works in determined increments, which is too fast and imprecise. especially since my mousewheel is not the 'clicking' kind. then im pretty much good to go....

Unfortunately, I don't think you can change the zoom increments.

I know what you are referring to though because I'm running into that same problem on the Mac's at school (which have a tiny little mousewheel and the zooming is super fast and erratically). I have a 'clicking' mousewheel and the zooming seems very comfortable to me. So unless you are very attacked to your mouse, you may consider getting another one that has clicking mousewheel.

no wait theres one more thing. ;) when i perform 'remove audio gaps' from the quantizer on a short section that was formerly of a longer section, it adds some long 'wings' of unwanted audio, instead of keeping it the length i chopped it to. how can i avoid this?

What you described is the purpose of the remove audio gap feature. After quantizing there will be gaps left from shifting the audio over, so the remove audio gap takes parts from the objects on both sides of the gap to fill them in so the audio is continuous and you don't hear the edit points. If there is a section that you don't want to have the audio gap removed from, then you would have to select everything and un-select the two objects on both sides of the audio gap you want left alone. Then it will only only remove the gap from the selected objects leaving that one (or several) gaps unchanged.

Hope that helps.

-tkr

Link to comment
Share on other sites

yeah...wow...jumpin' in big-time, this is good stuff (although obviously frustrating getting used to the paradigm).

All the zoom craziness and such can be hotkeyed to your habits or preferences.

There have been requests for options many ways (cursor in place, cursor migrate, cursor take priority, etc.), so I presume they're looking at putting switches in.

I'm so friggin' used to doing it the way it was designed to work from the onset, that I just work that way because I really don't know any better.

Plus, I span the entire VIP across 3 monitors ('cause I'm crazy that way), so that the cursor can do whatever it wants and it won't fly tracks back and forth to a centralized 'ergonomic' position - which is my preference so I don't have to search for the cursor. Obviously if I'm working on a laptop, then it's a whole other game.

Not sure about the mousewheel settings - although it may vary by manufacturer, and I seem to recall a request a while back for an .ini setting that would change the step, but I can't remember if/where there was a solution. You can try holding ctrl or shift key whilst wheeling and see if there is a tighter 'step' or no step resolution.

Hang in there, and it will all suddenly hit you soon enough that Samplitude just may be 'the one' ;)

Greg

Link to comment
Share on other sites

thanks for your help so far. workflow is coming along. i still cant quite manage a way to affect changes within an object globally for all instances or copies of that object. im talking about midi data now. if i have a pattern that i want to use throughout a project, is there a way for each copy of it to reflect changes, such as a note change in the pattern, in every instance of the same name?

also, is there a quick way to slide over crossfades as a whole without having independently adjust each end of them?

thanks again!

Link to comment
Share on other sites

thanks for your help so far. workflow is coming along. i still cant quite manage a way to affect changes within an object globally for all instances or copies of that object. im talking about midi data now. if i have a pattern that i want to use throughout a project, is there a way for each copy of it to reflect changes, such as a note change in the pattern, in every instance of the same name?

Sorry, I don't know of any way to do that. But here are a few ideas you could try.

Since the other MIDI objects are copies, you could simply delete the older copies and replace them with the new one.

Glue all of the MIDI objects together (as one MIDI object) this way you can select all of the MIDI notes you want to change at the same time, then your change will be made to all of the selected MIDI notes.

Also, if the MIDI objects are right next to each other you could set the first MIDI object as a loop, then changes in the first one will automatically be made in all of the looped objects.

also, is there a quick way to slide over crossfades as a whole without having independently adjust each end of them?

Select all of the objects you want to adjust the crossfades for, then press and hold the Alt key while you drag one of the crossfades over. This will make the same changes on all of the selected objects.

-tkr

Link to comment
Share on other sites

thanks tekker! the gluing tip sounds promising. ill play with that. but when gluing audio, isnt that the same as bouncing it? thats how ive been using it. and i dont really understand the strategic differences between linking and gluing. if i can just keep all the same parts with the same name glued then i can unglue them to modify one and just change its name so i dont accidentally reglue it to the others. that should work decently... if i glue something, i can unglue it right? guess i should just try this first.... thanks again.

Link to comment
Share on other sites

yea, as i thought, gluing just bounces objects into one (midi or audio). i need to keep them separate. linking doesnt seem to be the ticket either.

also, i cant seem to directly select crossfades. im just selecting the object. so holding alt only moves the edge of the one object and not the entire crossfade. i need a quicker way of doing this since the audio quantizer is so inefficient and often crossfading drums on the hit instead of right before, where it is more ideal. otherwise im getting the weird sounds of two hits right next to eachother. so i need to be able to move the entire crossfade accross several tracks over with one motion. otherwise i have to keep zooming in and out for the shorter xfades and move both edges, which is a total pain. seems quicker to just manually edit the obvious mistakes rather than mess with the quantizer at all.

Link to comment
Share on other sites

Yes, you can unglue objects.

In autocrossfade mode you should be able to use the alt+slide object corners (or crossfade nodes) and the crossfade will migrate as you slide it across the track (or widen the crossfade region if desired).

If this isn't working, then try using object-mouse mode.

The Audio Quantizing DOES work, but still needs some refinement. :angry:

Greg

Link to comment
Share on other sites

hey sirius, im always in object mode. but alt doesnt change the behavior at all. dragging on a crossfade just moves the object. alt only allows me to move the object if its locked. otherwise it doesnt seem to do anything. ive been playing with the settings, and the only time im seeing a highlighted crossfade is if i have asymmetric crossfades enabled. maybe this is why i can have to independently adjust each side? but without it, there seems to be no crossfading, regardless of auto crossfade setting. thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...