Jump to content
Sign in to follow this  
tlwebb

HW Controller controlling Mixer Monitor Level

Recommended Posts

EDIT: I should have mentioned the version, which is 11.03. Plus, I found something else. I again tried to assign a knob using the select box (and later by simply selecting the mixer knob) for Monitoring_Volume selection, and as before when I moved the controller, the solo monitor level changed. But then, for grins I tried to reassign that same knob to the solo monitor control and Samp told me it was already assigned to Monitoring_Volume. I take this to mean that the "learn controller" part of the process knew WHAT it was doing but something is wrong with the mapping from there to the actual parameter.

I'm guessing this is just a little bug, not an INI fix.

But still....

Hi

I'm using Samp V11 [Classic], WinXPSP2. Someone lent me one of those Korg nanoKontrol devices to play with and I was just messing around with it. I was trying to assign one of the pots to the Mixer Monitor Volume parameter. Didn't seem to work when I clicked the knob on the mixer, so I tried the "Program function" select box. Sure enough, it was listed in the pulldown under Mixer. The selection window says "Monitoring_Volume". But when I hit the Learn control, the entry in the list is "HWC_SOLO_MONITORING_VOLUME" and sure enough that's the function thats modified with the control. Thought maybe the labels were reversed and tried connecting to the solo volume, but it DOES control the solo volume.

Can this be fixed with an INI entry or something? Is the another way to assign a hardware controller knob to this parameter?

I did get other things set up properly (transport controls, four tracks fader to level, knob to pan, button1 to solo, button2 to mute) using the track increment and other nifties in the tool; it's just this one issue.

thanks

terry

PS This is really my first inquiry to the forum. I did a search over in the software, hardware and midi forums (I am a registered member) and didn't find anything. I really wasn't sure which forum was appropriate, and this is such a trivial issue compared to much of the stuff going on over there, plus, maybe other neophytes like myself have had a similar issue.

Share this post


Link to post
Share on other sites

hi terry!

thanks for reporting!

i reproduced your problem here. obviously a bug. if you need to control that parameter you need to edit the controller setup file manually.

- find your "controller".cps file subfolder "Controlpanels" in the samplitude program folder (where "controller" would be the name of the setting you have choosen in the hardware controller setup).

- use a text editor like notepad to open and fild the entry "HWC_SOLO_MONITORING_VOLUME"

- change "xx_slotnumber=0" into "xx_slotnumber=1"

if you try, please let me know if this does work for you too.

ciao falcone

btw:

you can also use the "learn hardware controller" function in the mixer. this would avoid the manual edit, but it wouldn't be as persistent.

Share this post


Link to post
Share on other sites

falcone

just got home from work and gave it a try. worked perfectly!!!

thanks so much

terry

PS I see I should at least put together a sig: never felt confident enough to post before, and this time I really didn't notice till my post sort of stuck out.

thanks again

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...