Jump to content

Bcf 2000 Question


PERKINS
 Share

Recommended Posts

Hi i"m new here,just purchased a BCF 2000 for SAMP 10 to get a faders touch to my mixes.I got it working in Mackie control

& Mackie baby hui mode,everything works where I want it the only thing is how do you control the master faders in these

modes.What sequence of buttons or fader movements achieve this result.

Link to comment
Share on other sites

hi PERKINS!

original support for hardware controllers in samplitude started with mackie control. so some things in function design are oriented on that controller.

the bcf 2000 has 8 faderts for the 8 tracks. the mackie has the 8 faders for 8 tracks and one additional fader for master. so the normal track-fader where never regarded to control the master in that case.

at this point your (and of course our) problem starts.

there are three solutions currently there (Samp V10.1) for you:

1: you regard faders 1-7 as track faders (so you would have only a 7 track controller). the 8th fader would be the master fader. to do this, go to the controller setup and set up your controller. (as you described you use the mackie template and it works. so you already set it up.) click on "save as.." to create a copy of the original mackie template and work with the self named copy. the set "track number" to 7. switch to "customize controller". find the entries "TrackVolumeFader" track 8 and delete it from the list. also do this with "TrackVolumeFaderTouch" track 8. now you disconnected the samplitude function from the midi messages sent by the fader number 8. now you have to connect these midi messages to the master fader sam functions. so select as program function "mixer -> master -> fader master" then touch your fader number 8 and move it so that there show corresponding midi messages. hold the fader till you clicked "learn", because on release ther would be the fader touch off message. now you can mode the fader and it should select "Master_Fader" in the list. learn the fadertouch "mixer -> master -> fadertouch master" to the midi data showing on fadertouch release.

2: learn a button to "mixer -> navigation -> Assignment Track". this button would activate / deactivate the "active control" mode. in active control mode you can select in the mixer the master fader and control it via the first fader.

3: use the v10.1 introduced functionality for midi learn. to do so open the mixer click on the icon in the left upper corner of the mixer to get the system menu. select "learn hardware controller" and click the master fader via mouse (maybe change it a bit). then grab your fader of choice on the controller and move it. now the connection between these two should be created and you control the master via the fader. this connection holds as long as you don't change any hardware controller setting, click "restore mode" in hardware controller setting or delete the corresponding file in your samplitude directory.

i hope this helps you to solve the problem

ciao falcone

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...