Jump to content

Mmc Transportcontrol Problem


Sir Stony
 Share

Recommended Posts

Hallo

Ich habe mir vor drei Tagen einen CME Bitstream3x zugelegt um damit Sam (10.1 pro) ein wenig komfortabler zu steuern. Dabei habe ich aber festgestellt, daß ein Spul-Befehl (egal ob ffwd order rew) von dem Controller nur als einmaliger Befehl geschickt wird und man den Spulvorgang manuell stoppen muß. Eigentlich würde ich an dieser Stelle erwarten, daß ein Stop Befehl das bewirkt, stattdessen aber muß ich den Play Befehl schicken um das Spulen anzuhalten. Stop wirkt nur im Play Modus. Liegt das am Controller, oder an Sam, oder an mir?

Link to comment
Share on other sites

... so wie Du es schilderst, erst mal eher am Controller. Was soll denn passieren, wenn der Stop Befehl nicht kommt? Wenn der Controller denkt dass er das nur nach Play senden möchte, dann ist das eben so.

Was natürlich auch sein könnte: Der Controller bekommt aus irgend einem Grund den Zustand von Samplitude nicht mit. Das könnte jetzt entweder daran liegen, dass der Controller Samplitude nicht fragt, oder dass Samplitude ihm keine oder inkompatible Rückmeldungen gibt. (?)

Grüße,

Sebastian

Link to comment
Share on other sites

thx Sebastian

Hm. Erstmal folgendes: wieso sollte der Controller eine Rückmeldung von SAM brauchen, wenn er weder Motorfader noch anderweitige Zustandsanzeigen hat? Das Display zeigt nur an, was im Controller vor sich geht, nicht was der Rechner macht. Es ist, glaube ich, auch nicht anders vorgesehen. Ich denke, daß der Controller auf jeden Fall den Stop Befehl sendet, gerade weil er nicht darauf ausgelegt ist irgendeine Rückmeldung von der Software zu erwarten.

Schöner wäre es natürlich überhaupt nur solange zu spulen wie man den Button gedrückt hält, dieses Verhalten allerdings scheint die aktuelle Firmware des Controllers nicht für die Transportbuttons vorzusehen, und ich weiß auch nicht wie hier die genaue Syntax für MMC Befehle aussehen muß. Aber egal... wenn "Stop" stoppt, bin ich schon zufrieden. Vorerst.

Der Großteil meiner anderen kleinen Problemchen mit dem Controller wird sich wohl durch die Editor Software und die geduldige Abstimmung mit SAM richten lassen - auch wenn ich mir eher eine Zeitersparnis anstatt zusätzlichen Aufwand erhofft hatte.

Ich fahre jetzt nochmal ins Studio und sehe mir es genauer an, auch wenn ich mir (fast) sicher bin, daß es nicht am Controller liegt. Ein Midi Monitor wird es einfach aufklären.

Toll wäre es natürlich, wenn zu SAM und dem bitstream ein passendes Controllersetup zu bekommen wäre, aber vermutlich ist das einmal mehr die Situation in der weder der eine noch der andere Hersteller dafür herhalten wollen. Und für die edlere Variante, die ich als einzige Alternative in Betracht ziehen würde, gibt es meines Wissens nach bisher auch noch nichts... das wäre dann die Euphonix Artist series. Die große MC5 ist mir zu fett (und teuer), ich habe bereits ein 32ch Analogpult plus siderack und keinen Platz mir noch so'n Brocken daneben zu stellen. Mal sehen, was wird.

cheers, Joe

edit: Meine Annahme, der Controller würde kein Feedback erwarten, war so nicht ganz korrekt: bei aktiver Rückmeldung habe ich zumindest auf dem Controller eine Playtime/Taktanzeige. Alles herumprobieren hat aber bisher nichts an dem merkwürdigen Stopverhalten geändert. Midi Monitor bestätigt auch meine Aussage, daß der Controller den Stopbefehl in jedem Fall ausgibt.

Link to comment
Share on other sites

Also, wenn der Controller taub wäre endete die Causa jetzt und hier. Denn dann gilt: ohne Stop Befehl kein Stop. Der Rest wäre mit CME zu klären.

Nun, da Du später sagst dass der Controller doch nicht ganz taub ist empfehle ich weitere Forschungsarbeit Deinerseits (z.b. mit MidiOx lesen und Befehle händisch senden), und eine zielgerichtete Rückmeldung was das Ding nun wirklich tut. MMC ist eigentlich recht standardisiert. Ich frage mich, was da anzupassen wäre? Eher ist da was buggy auf der einen oder anderen Seite.

Grüße,

Sebastian

Link to comment
Share on other sites

Der Controller sendet die Befehle ja alle. SAM stoppt nur nicht, wenn ich (per Controller) spule und dann stop drücke. Es ist das Verhalten von SAM das mir hier Kopfzerbrechen bereitet, und ich habe noch keine Option gefunden, mit der ich das Verhalten der Transportbuttons beeinflussen könnte.

Was ich gerne hätte:

einmal Stop: Pause. (Pause würde auch den Spulvorgang anhalten)

nochmal Stop: Stop und zurücksetzen an den Ausgangspunkt.

Auch ganz nett wäre z.B. die Spulbuttons statt zum spulen als Markersprung oder Taktsprung konfigurieren zu können.

Grüße, Joe

PS: vielleicht sollte dieser Beitrag ins normale Forum rübergeschoben werden, da hier im Newcomerboard ja dransteht: kein offizieller Support. Und genau den suche ich ja eigentlich.

Link to comment
Share on other sites

Hallo

Ich habe mir vor drei Tagen einen CME Bitstream3x zugelegt um damit Sam (10.1 pro) ein wenig komfortabler zu steuern. Dabei habe ich aber festgestellt, daß ein Spul-Befehl (egal ob ffwd order rew) von dem Controller nur als einmaliger Befehl geschickt wird und man den Spulvorgang manuell stoppen muß. Eigentlich würde ich an dieser Stelle erwarten, daß ein Stop Befehl das bewirkt, stattdessen aber muß ich den Play Befehl schicken um das Spulen anzuhalten. Stop wirkt nur im Play Modus. Liegt das am Controller, oder an Sam, oder an mir?

Kontakte doch mal Dejan (forum member aus Slovenien). Er arbeitet mit einem bitstream und ist sehr zufrieden. Scheint problemlos zu laufen.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...