Jump to content

To the developers of Vandal


Vandal
 Share

Recommended Posts

First of all, I wanted to write an email, then I figured out more people could see and discuss my ideas, so here goes...

Hails to the Magix staff for creating the most amazing virtual AMP ever!

As much as I adore Vandal and consider it my best investment ever (I also own Guitar Rig 4, and I hate how CPU intensive it is), I've also noticed some trouble running it earlier (in reaper, thank God you guys fixed those knob issues), and the thing that bugs me in the new version is, whenever I have my vandal up for a long time, or play on my midi keyboard, it seems that volume shifts somehow, I don't know how to explain it, but it simply rises and falls off in a matter of seconds, then it rises again... This is a really odd bug, and I have had no trouble registering the product whatsoever (also, this didn't happen in versions prior to v1.104).

Also, some things I would suggest:

1. Reaper doesn't see scene selection as a midi envelope, and doesn't seem to be able to select scenes via CC controls, I think one knob extra (4-way, for scene selection), to go with remote 1 through 5 wouldn't hurt.

2. It would be awesome if there was an option "inphase" when it comes to mics, see, since I use software mics in Vandal, it'd hard to measure the distance between those, and some phasing problems might occur (I've had some issues with this). What would "inphase" knob do? Well, it'd adjust the second mic into a perfect position, which would make phase issues non existant. Normally, after some tweaking I'm able to set everything fine, but for inexperienced people this could be a huge audio-damaging issue.

3. Make graphic EQ (on the pedalboard) have an option "domain" where the user could set how much he wants to change the volume of a certain frequency. Frequency choice is good, but I just feel that the domain of the graphic EQ is too small, and would like it to have choosable dB domains like "6db, 12db, 18db, 24db". Another thing to add to the graphic EQ to make it more useful is the "Q" option, but is not as necessary.

4. CheWahWah is one of the best digital wah effects I've heard, but doesn't seem to cope with the bass guitar very well, how about making BassWah? The real issue is that normal wah shifts high frequencies (no matter how I set the knobs), and it should shift lower ones for the bass, this'd take very little reprogramming to make it work, and is also only a luxury, least important of all those suggestions.

5. I wish that chorus, flanger, and other mods had a "BMP" setting instead of "rate" (I think I saw something like that in amplitube metal demo), and that the user could see actual values (like 120BPM, 140BPM), because that way it'd be much more useful when working in a DAW (and anyone who uses Vandal will be using one, anyway, since Vandal has no standalone version). A nice thing would be to have a "sync" option as well (such as the one in Digital Delay) that would basically lock the BMP (or rate) to one provided by DAW. Then, after that "sync" option, it'd be great if it had an option to set the duration of the modulation circle, be it 1/2, 1/4, 1/8, like some rack effects in Vandal have. I'm really struggling to incorporate modulation effects in my project because I can't have it go well with my tempos (they are, however, real quality).

Those are suggestions that would (arguably) make the Vandal VST much better, although it is already as great as software amps go (better than any 500mb amps on the market, with lots of useless impulse responses). I really would like to see some of those changes in the next few versions, as that'd make Vandal and my (and also other people's) use of it much more versatile.

Wish you all the best, and to continue creating amazing software!

Link to comment
Share on other sites

I don't know how to explain it, but it simply rises and falls off in a matter of seconds, then it rises again... This is a really odd bug, and I have had no trouble registering the product whatsoever (also, this didn't happen in versions prior to v1.104).

Just a quick question (curious here): in which host does this happen? I can't reproduce it here, neither in Samplitude, nor in Reaper.

Link to comment
Share on other sites

I don't know how to explain it, but it simply rises and falls off in a matter of seconds, then it rises again... This is a really odd bug, and I have had no trouble registering the product whatsoever (also, this didn't happen in versions prior to v1.104).

Just a quick question (curious here): in which host does this happen? I can't reproduce it here, neither in Samplitude, nor in Reaper.

Thanks for your quick reply, it happens in Reaper, and when I close the project and load it again, it doesn't fix it. Even if I change the preset, the volume still varies, and when I delete Vandal from FX chain, and add another vandal instance, and set my preset (that was buggy prior to the new instance), it works fine. I haven't had trouble with this for over six hours I've been running Reaper, and it happened three times yesterday, so I don't know what I do to trigger it (I really customize every single bit of Vandal, so it's hard to identify it that way).

EDIT: As soon as I opened Reaper, this bug persists. Here, I will attach the file, check it out for yourselves.

EDIT2: The problem seems to occur every time I save, exit Reaper, then load the project again.

Cant_explain_it_really.zip

Link to comment
Share on other sites

RE the Wah suggestion - I would prefer something akin to a Parametric EQ, so the Q etc can be chosen be me (for that "wah stuck on but not quite so strong" tone).

BTW, I have had no issues with Volume level changes using Vandal within Samp & Brainspawn Forte.

I have said it before here & I'll say it again, I have used a Fractal Audio Axe FX Ultra for a while & the Vandal kicks its little bottom. There are of course routing attributes that are better in the Axe (as you would expect at that cost) but tonally it is lacking & "2D" sounding compared with the Vandal.

If there were ever a hardware version, I would buy it.

Over,

Bob.

Link to comment
Share on other sites

One more bug noticed, while I was messing around Vandal:

If you set amp type to "- No Amp -" and then try to load an amp template, Vandal (and the host) crash.

Argh, sorry. Haven't seen that before. I'll be on vacation the next two weeks, but I'll look into that as soon as I get back.

About the other problem, can you please do the following:

- please download and unzip this tool: http://www.winmd5.com/download/winmd5free.zip (it's very small and doesn't need installation)

- go to the '_bin' subfolder of your Vandal installation, and drag&drop these files onto the winmd5 window:

IJL10.DLL

MagixOFA_u.dll

MagixOFA-en.dll

MFL_u.dll

Protein.dll

PlayRIpl.dll

PlayRIplPX.dll

-let me know about the strings the tool spits out

Thanks.

Link to comment
Share on other sites

Not only does Vandal's volume go up and down, it also RANDOMLY FREEZES REAPER AND MY PC, but it seems I've found a way around everything.

Reinstalled vandal to C:\, re-registered it, then compared the checksums of all DLL files (including vandal_vst.dll), and they were ALL different. I asked a friend what could cause that, so he told me to download Avast and scan my PC, since "viruses can do that". It seems that ALL my .dll and .exe files (standalone kontakt and standalone philharmonik) in VST directory are damaged or infected! I have yet to scan the whole drive for viruses, but good lord... Healing the files just turned them into less-than-100kb files that can't be used for anything, so it seems I will have to reinstall all VSTs anyway. Avast said those files contained some Trojans and Worms (also some "dll injection" stuff, don't understand this). I reinstalled and re-registered Vandal now, and everything works perfectly fine (except for the little bug noticed up there), if it weren't for this "bug" I could've run an infected computer for years! Now I got an explanation for weird Reaper and Kontakt crashes too...

Well, Sascha, sorry for beating your head over this "bug", which isn't your fault (and driving your focus from more important things)! Enjoy your vacation, take your time and continue improving this amazing software!

Link to comment
Share on other sites

Reinstalled vandal to C:\, re-registered it, then compared the checksums of all DLL files (including vandal_vst.dll), and they were ALL different.

Hang on a second. No need, to reinstall and 'compare' the files on your side. At least not against each other, that's of no use. I just need the raw checksums of each one.

About the 'virus issue'. Often, scanners produce false positives. Plugins may trigger their alarm system because they often operate on a very low level, 'close to the machine', if you want. And many are unpacking certain parts at runtime, which a scanner could interpret as 'self-modification', thereby sorting it out as a virus.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...