Jump to content

Help Request: Samp Pro X5 Sampling Rate Headaches


B K
 Share

Recommended Posts

Hello! I’ve worked with Samplitude for many years, and I recorded most of my stuff with Echo Audio’s Gina interface. My previous setup was a Dell running Windows XP and (I think?) Samplitude 6. I took a break of several years due to my increasing workload and other issues. When I found the time to get back into recording, I needed to upgrade my PC and interface, so I went with the Behringer UMC404HD and an Asus M32CD running Windows 10. Processor: Intel Core i7-6700 CPU @ 340 GHz; x64-based. Installed RAM: 8 GB. I also upgraded to Samp Pro X5. 

My problem is, my old recordings play at roughly double speed, and this seems to be independent of changes either to the Behringer control panel or to the VIP preferences. I’ve experimented with multiple combinations of sampling rates, but the playback speed hasn’t changed.

(Actually, that’s not quite true. A couple of times, it did slow down to something approaching the correct speed. But that lasted only until I stopped playback. When I hit Play again, it was fast. And weirdly, reentering that sample rate didn’t correct the speed a second time.)

The only clue the PC’s given me is an occasional (i.e., nonreproducible) warning that “the audio card is synchronized to an external clock.” I haven’t seen that message in about 24 hours, though — maybe it’s resolved? I don’t see any obvious way to check this.

Stuff I’ve tried (besides experimenting with the sample rate in Samplitude and the PC’s Playback Devices windows): Uninstalling / reinstalling the Behringer driver (it’s up to date) with the device unplugged. Disabling all onboard audio cards and speakers. Disabling all system sounds. Preventing the computer from cutting power to the USB ports. Toggling the driver in and out of Exclusive Mode. Plugging the UMC404 into various USB ports (only 3.0 seems to work). And probably a bunch of other stuff I’ve forgotten.

I’ve used the UMC404HD with Audition on my Mac with no problem, so it’s not a hardware issue. My understanding is that Behringer’s drivers are a bit spotty, and it seems clear to me that Windows 10 is...well, let’s just say not quite perfect, so I assume the problem lies somewhere in their interaction. I’m out of ideas at this point, and I appreciate any suggestions you folks may have! (Including other sound cards, if that’s the only way out of this mess.)

Thanks!


 

I’ve installed the most recent 

 

Link to comment
Share on other sites

Hi @B K!

What driver type are you using in Samplitude's Audio Setup, Driver System?

Asio? or are you using Windows MME or WDM?

As I recall your old Samplitude 6 didn't have Asio, only MME & WDM so maybe you overlooked the Asio option?

Use Asio, the VIP sample rate should set the sample rate for the Audio interface.

As you got the “the audio card is synchronized to an external clock.” I suspect that you might be using MME and Windows has locked the sample rate for something else ...

Best, Thomas

Link to comment
Share on other sites

Thanks so much for your response, Thomas! I apologize — I should have mentioned above that I’ve had Samplitude’s driver system set to UMC ASIO Driver throughout this process. The clock source is “Computer,” and the UMC Control Panel says “ASIO active (PCM mode).”
Looking at the UMC 404HD properties, I do notice under “Events” that It says “Device USB\VID_1397&PID_0509\6&11f1vv8e&0&4 requires further installation” — no idea whether that’s relevant, though.

Could the lack of ASIO on my old setup be the issue? What I find really weird is that when I change the sample rate under Project Properties, the audio clips will shrink or expand due to resampling, but the incorrect playback speed remains constant.

I guess if all else fails, I can learn to love the sped-up versions — they’re kind of interesting!

Thanks again, 

BK

 

Link to comment
Share on other sites

25 minutes ago, B K said:

What I find really weird is that when I change the sample rate under Project Properties, the audio clips will shrink or expand due to resampling, but the incorrect playback speed remains constant.

That's correct, it should do that is you change the project sample rate.

Somewhere there's a sample rate mismatch, we just need to figure out where ... :)

What is the original sample rate of the wav files and the original VIP?

Link to comment
Share on other sites

When I opened Samp just now to check the sample rates, I got a warning: “UMC ASIO Driver loading failed.” First time that’s happened! Reopened the program and didn’t get that message. Odd,

Anyway, the WAV sample rates are 24/96 in all the projects I checked. However, I notice that in a couple of cases, the VIP includes a track or two at 88200 for some reason. The original VIP was 96 as well.

 

Link to comment
Share on other sites

One additional data point: I opened a VIP in Samp 6, went to "Playback Options" and changed the sample rate to 48000, at which point the music played at the correct speed. (Unfortunately, I'm stuck in demo mode until I can figure out where I left my installation disk!)

The Device Info / Playback Capabilities window for the UMC 404HD says "WDM compatibility is active," which I assume is why I'm able to hear the tracks at the correct speed. Don't know if this is relevant but thought I should mention it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...