Jump to content

Beat matching and automated EQ


tempacct
 Share

Recommended Posts

Hi!

I'm looking for a good software to make mix-CDs, as in the DJ sentence.

I've looked a little at Samplitude and have two questions.

1. The first thing I need is to make several tracks go in the same BPM. The only way with precision enough I've found is to mark a range of four bars and from the range manager calculate the BPM, this has to be done for each song in the mix. Then

use the "destructive" resampling function (I'm not interested in pitch shifting/time stretching), with the aquired BPMs.

Is there another, more easy way, to do this as it is tedious work to make all ranges (with the zooms and everything :blink:)?

2. When two or more tracks are playing simultanious it's often needed to tweak the EQ to avoid cliping and bad levels in general. Is there a way to set points in the track to automate the EQs in the mixer (it would be valuable to avoid the destructive part here as ther's a lot of twiddling involved)?

Best Regards!

Link to comment
Share on other sites

1. The first thing I need is to make several tracks go in the same BPM. The only way with precision enough I've found is to mark a range of four bars and from the range manager calculate the BPM, this has to be done for each song in the mix. Then

use the "destructive" resampling function (I'm not interested in pitch shifting/time stretching), with the aquired BPMs.

Is there another, more easy way, to do this as it is tedious work to make all ranges (with the zooms and everything :blink:)?

Have you tried the remix agent? I haven't really experimented with it, but that may do what you are looking for.

As a side note about the zooming, you can set the navigation functions (zooming and scrolling) to your mousewheel with the press of different function keys and that makes navigating in Samp incredibly fast. Here is how I have mine setup.

Horrizontal Scroll: Mousewheel

Horrizontal Zoom: Ctrl + Mousewheel

Vertical Zoom: Ctrl + Shift + Mousewheel

Wave Zoom: Ctrl + Shift + Alt + Mousewheel

Vertical Scroll: Shift + Mousewheel

Change Active Track: Ctrl + Alt + Mousewheel

2. When two or more tracks are playing simultanious it's often needed to tweak the EQ to avoid cliping and bad levels in general. Is there a way to set points in the track to automate the EQs in the mixer (it would be valuable to avoid the destructive part here as ther's a lot of twiddling involved)?

You can't automate the EQ, but you can split the objects where they overlap and then use the object editor to apply EQ only on the parts that overlap.

-tkr

Link to comment
Share on other sites

Nope, haven't tried the remix agent, didn't know about it till now. I'll check it out! :blink:

I might have found a better way to do my work though. When double clicking on an object it is, from the dialog that pops up, possible to change the objects default time stretching method to resample. When that has been done it's just a matter of resizing the objects graphical representation to make the beat match some other track. I believe these changes are processed in "play time" so it's extremly quick to work with as well.

However, when I export the project to wav either by the File menu or the mixdown button in the mixer dialog, the result sounds nothing like when it's played directly in samplitude, it almost sounds like the reasampling is correct but the start time of the object has been moved slightly. Any ideas what that's all about?

Thanks for the zooming and EQ tips btw!

Best Regards!

Link to comment
Share on other sites

However, when I export the project to wav either by the File menu or the mixdown button in the mixer dialog, the result sounds nothing like when it's played directly in samplitude, it almost sounds like the reasampling is correct but the start time of the object has been moved slightly. Any ideas what that's all about?

No, I don't. I have never had any problems with the time stretching..... It maybe a bug from v8.11, but I'm not sure on that.

Also, another thing you can do for time stretching is on the toolbar there is a mouse mode called "Pitch Shift/Time Stretch", when you click that, then the handle in the middle of the object adjusts the pitch of that object and the handle on the bottom right of the object will stretch the object. So you can manually drag the object to the exact length you want instead of having to use that knob to adjust it (which is a lot more difficult).... This is a great way to do it if you have to adjust multiple tracks, because then you can select all of them at once and they all will be dragged together (it seems to react differently if you use the knob in the object editor). You can also turn the "snap" feature on and if it is set to snap to other objects, then you can also quickly snap other objects into the same time.... Lots of very cool options to use here. :blink:

-tkr

Link to comment
Share on other sites

Hmm. It appears I've mistaken myself regarding the playback anomalies mentioned before.

It's just like I said but the same problem appears while playing the entire track directly in samplitude. However, if played from right before an object mixes in to the next one everything sounds ok! And the same goes for mixdowns to wav, if I start the dumping right before a mix that particular mix sounds good.

Now that's a bug if I ever saw one.

Best Regards!

Link to comment
Share on other sites

Guest quicksound

Hi tkr, sorry to butt in on this thread, but I'm using demo version 8.11, considering crossgrade to sam from cubase. I have a similar problem to tempacct with recording / playback. Audio is fine and has never sounded better, but when recording a midi track (real time playing) to an existing project, on playback the midi tk is never in synch to the existing tracks. It has to be manipulated carefully to the correct start point then timestretched using trial and error, which is REALLY frustrating and can take a long time to get right. Has this been addressed in 8.2? Thanks if you can help.

Cheers Gary

Link to comment
Share on other sites

Hi tkr, sorry to butt in on this thread, but I'm using demo version 8.11, considering crossgrade to sam from cubase. I have a similar problem to tempacct with recording / playback. Audio is fine and has never sounded better, but when recording a midi track (real time playing) to an existing project, on playback the midi tk is never in synch to the existing tracks. It has to be manipulated carefully to the correct start point then timestretched using trial and error, which is REALLY frustrating and can take a long time to get right. Has this been addressed in 8.2? Thanks if you can help.

I'm not really sure, I don't work with MIDI as I'm strickly an "audio" guy. But hopefully someone else can pitch in here and give you an answer.... :blink:

-tkr

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...