Jump to content

midi recording


ananto
 Share

Recommended Posts

I would be happy if somebody could help me out with this. I'm a Magix Music Maker 2006 user and i wanted to try out samplitude. I like the program a lot, but i'm having a problem with midi recording.

Playing Vsti's with my midi keyboard works fine (monitoring ok. ) but the problem arises when i record, the midi info is written into the pianoroll with about one full second of delay !!!

I.m using sempron 3000 with 512 ram.

Any advise?

Link to comment
Share on other sites

If you go into system prefs for midi, you can set an the offset to account for the delay.

However, you may want to check your midi drivers and be sure they are up to date. That can also cause delay/offset in midi recording.

Link to comment
Share on other sites

Go to Options -> System/Audio (y is the shortcut key command), and select Midi. Half way down there is a Record Offset option in msec. I don't know that you would need a full 1 sec - check to see how long the delay is, and start with that value as a negative: e.g -1000 for a full 1 sec delay, but I doubt you will need nearly that much. See what -10 does first and work from there.

Midi drivers would be under WinXP's Device Manager under Sound, video and game controllers - check properties-driver for your midi device to see what version the driver is.

Link to comment
Share on other sites

Ok, i tried it and found out that every vsti has a diffrent delay. i succeeded to syncronize one vsti, but then recording a second one on another track gives me another delay value, and it's impossible to syncronize the second track with the first one.

As far as drivers, i tested vsti recording on cakewalk sonar trial version, and it works perfectly. also midi recording with music maker works perfectly. my computer is a brand new HP and doesn't seem to give problems with other programs so i guess that samplitude trial doen't like my computer or that there's some sort of bug . a pity because i was thinking of purchasing samplitude.

Link to comment
Share on other sites

What midi interface are you using? USB or other?

Audio card?

Cpu?

I have an Emagic Unitor 8mkII (using the serial port), and with the stock driver, midi timing was off, but after updating to the last known surviving version it works fine with Samplitude. The driver may not be the issue necessarily, but it seemed to solve timing issues I was seeing. VSTi's all play at very low latency here, so at least there may be a solution for you.

Link to comment
Share on other sites

i use a m-audio 61 keyboard, usb connected.

soundcard is soundblaster 5,1

cpu is a sempron 3000.

by the way, playing (monitoring) a vsti there is no latency, using the magix low latency drivers.

i,ll see if i can get the latest drivers from m-audio.

thanks.

Link to comment
Share on other sites

Unfortunately I don't have any other suggestions. It may be an issue with your audio card. Samplitude should work with most audio cards, but it could be the 5.1's drivers causing inconsistent or uncompensated latency. Most newer SB cards (Audigy and Extreme), and others geared towards professional/semi-pro audio apps support ASIO2 drivers which work well with Samplitude.

In general, MME is fine for Windows media apps, etc, but not the best choice for DAWs like Samplitude, Sonar, Cubase, etc. I believe the 5.1 only runs MME drivers. That may not be the problem, but I also wouldn't be surprised if it is. An audio card that supports ASIO may be a better choice.

Link to comment
Share on other sites

Guest FrankProposch

Try the following .ini file modification:

Sam.ini (or similar, e.g. Sam8_E.ini) : add the following line in the [setup] section:

IndirectMidiThru=0

If [setup] doesn't exist in your .ini file, simply add both lines to your .ini file (best at the end so you don't break any other [section]):

[setup]

IndirectMidiThru=0

Link to comment
Share on other sites

When he can use the monitoring function with vsti

he IS using asio-drivers or am I wrong? (MME and monitoring?).

Are there other applications running at the same time?

I use a Marian Marc8 with 2 Midi Ins/Outs and got the same problem by sending the keys midi-out two both midi-ins.

Solved the problem by deactivating the second midi signal.

@FrankProposch:

What is the -IndirectMidiThru=0- for exactly?

Link to comment
Share on other sites

  • 2 months later...

Can you try if the standard MIDI output of your M-Audio keyboard works instead of the USB connection?

in the Sam.ini file,

[setup]

IndirectMidiThru=1

is an option which avoids problems with faulty midi drivers which cannot accept to calls in the same thread.

IndirectMidiThru=0 gives faster (direct) MIDI Thru, but may crash with some midi devices. This is not very likely, so it is worth a try to set IndirectMidiThru=0.

If you still have problems with midi recording, you can also try

[setup]

MidiInDontReopenDevices=1

which changes the way MIDI Devices are called for recording.

Greetings,

Frank

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...