Jump to content

New Se User - Auto-quantize? Midi Event List Editor?


Resonance
 Share

Recommended Posts

Brand new V8 SE user, but I've been a die-hard Logic windows user since forever and I'm still with Logic 5.5. Looking seriously to make the switch to Samplitude Pro or Sequoia hence my trying the Samp SE version.

Looking for a standard auto-quantize or auto-groove-quantize feature in Samp SE - please tell me it has one. I don't like having to stop and seperately quantize every MIDI take I play as it really disrupts the flow ideas. I checked the help file but it only shows quantizing in the MIDI-Object editor window and nothing about auto-quantize.

And I'd like to know if there is a MIDI event list editor similar to Logic's? Highlighting individual notes in the MIDI-object window in Samp and manually dragging them to different keys is far slower than just highlighting a bunch of notes in a list editor and typing in the note you want them all to change to... Logic does this very elegantly. Don't know if there is something similar in Samp...

Other than those two things (which are deal breakers for me unfortunately), Samp looks great. :wacko:

Thanks.

Res

Link to comment
Share on other sites

Looking for a standard auto-quantize or auto-groove-quantize feature in Samp SE - please tell me it has one. I don't like having to stop and seperately quantize every MIDI take I play as it really disrupts the flow ideas. I checked the help file but it only shows quantizing in the MIDI-Object editor window and nothing about auto-quantize.

Sorry Res but there is no Auto Quantize in V8 . It was on the wish list for V9 but I don't know if it's been added as my copy hasn't arrived yet.

And I'd like to know if there is a MIDI event list editor similar to Logic's? Highlighting individual notes in the MIDI-object window in Samp and manually dragging them to different keys is far slower than just highlighting a bunch of notes in a list editor and typing in the note you want them all to change to... Logic does this very elegantly. Don't know if there is something similar in Samp...

There's an icon at the top left of the Piano Roll just below where it says Event. Try clicking on that or press ALT+L . Experiment with the display filter . It's quite useful .

Regards

Kraznet

Link to comment
Share on other sites

Thanks Kraznet.

I found the MIDI Event List last night just clicking around the MIDI edit window - and the display filter buttons are a handy feature. Very cool.

Can't believe there's no auto-quantize in this app at version 8... 8 versions is a long time to ignore such a basic feature. I've been looking for 'Logic-esque' auto-quantize with the various time and swing variants in a DAW since it was sold to Apple, and still no luck. :wacko:

Oh well - I can't get the MIDI recording to work properly anyway. I've tested so many demos on my current system and none of them have had MIDI timing issues like Samplitude. Everything's been rock solid and fairly sample accurate up until now. Sonar, Acid, EnergyXT, Live - every demo works great on my system.

When I'm playing MIDI into Samp with the click running, I'm practically dead on the beat. When I play it back, Samp has my recorded MIDI starting a full quarter note early and then it drifts into time by the end of the recorded sequence. Could be a bar long - could be 16 bars long - doesn't matter, the same drifting happens. I've never seen anything like it before.

This shouldn't happen in a product that claims to be professional - and sells at the price it does (I know I'm only using SE but it's based on the same $1000 engine right? Just a cut-down version with limited channels, inserts, and effects?). I've scoured this forum looking for a solution and I notice a lot of people have had the problem - but I don't use MIDI yoke, so that fix was out. I tried all of the buffer fixes suggested. I tried using sync. I tried not using sync. I tried deleting the SampE.ini. I spent hours futzing with this app trying to get it to smoothly record a simple drum loop and it's a no go.

I'm actually pretty bummed about it because Samplitude looks like a perfect fit for my studio, and Logic 5.5 is so long in the tooth now - no PDC, no freeze, newer plug-ins don't show up, etc. Samp is the closest thing to Logic on the PC that I can find, but solid MIDI is a must.

I haven't even had a chance to try out the audio features in Samp yet - there's a lot of posts on this forum about people sequencing MIDI in one app and then using Samp for audio because the engine is so good. But I refuse to do my work in two different programs - totally defeats the purpose of an all-in-one DAW with MIDI and audio if that's the sort of workaround that you have to do. I swore I'd stop doing that when I sold my entire EMU PARIS system - used to sequence in Logic (before it was Logic Audio) and record in PARIS while using a MOTU timepiece sync box to control it all - WAY too much trouble.

Sorry for the mini-rant - like I said I'm just bummed out. I was really hoping to find my way around Samp SE this weekend and then upgrade by early next week before starting a bunch of new projects.

Res

Link to comment
Share on other sites

When I'm playing MIDI into Samp with the click running, I'm practically dead on the beat. When I play it back, Samp has my recorded MIDI starting a full quarter note early and then it drifts into time by the end of the recorded sequence. Could be a bar long - could be 16 bars long - doesn't matter, the same drifting happens. I've never seen anything like it before.

Hi Res ,

I've been checking this out on my copy of SE and I'm getting a similar amount of offset as well. I've discovered something though. If I delete the offset midi notes from within the Piano Roll editor , leave the editor open and then record again but this time with the editor open the timing seems to be fine . It seems that as long as the piano roll is open the timing is ok . As soon as I close the Piano Roll and record in just the Arrange the timing goes off again . Very weird!! Maybe you can try this and see if it's the same for you . I'm still testing so this is just preliminary .

Cheers

Kraznet

Link to comment
Share on other sites

Hmm I'm getting exactly the same behaviour Samplitude Pro 8.31. I've come from Logic as well but I haven't recorded a whole lot of midi in Samp which I probably why I never noticed anything . Most of my midi recording was done in Logic and either rendered to audio and bought into Samp or I imported the midi files for editing so this is a worry for me .

Also as a work-around it seems if you go to Midi>New Object>Empty this allows you to open an empty Piano Roll and then the first take is in time but as soon as the Piano is closed the timing goes adrift again next time you record :wacko:

Regards

Kraznet

Link to comment
Share on other sites

Hmm I'm getting exactly the same behaviour Samplitude Pro 8.31. I've come from Logic as well but I haven't recorded a whole lot of midi in Samp which I probably why I never noticed anything . Most of my midi recording was done in Logic and either rendered to audio and bought into Samp or I imported the midi files for editing so this is a worry for me .

Also as a work-around it seems if you go to Midi>New Object>Empty this allows you to open an empty Piano Roll and then the first take is in time but as soon as the Piano is closed the timing goes adrift again next time you record :wacko:

Regards

Kraznet

Hi

I've been trying to record midi in one form or another using Samp V8 SE for about six weeks and constantly get issues, mainly that sync recording is useless so what's the use in including it in this teaser 'Semi Pro'

package.

The problems I have are here http://support.magix.net/boards/samplitude...?showtopic=9395

Have tried Frank's suggestions still no go.

I really do think Magix should sort the whole Midi recording problems out now with a patch or they will lose customers including me before I even think of upgrading to a shakey V9

Regards

Brian Cadoret

Link to comment
Share on other sites

Thanks for the feedback Kraz - it's greatly appreciated. :wacko:

I tried your piano roll experiment and it sort of works BUT now does what I was saying before only backwards! It starts out in time, and then drifts out by the end of the sequence by speeding up... Which I guess is exactly the same thing only starting in the right place and ending up in the wrong place instead of vice versa. Try it again on your system to make sure it's not still speeding up.

Totally weird. Samp is definitely the culprit here, 'cause I've never encountered such a problem before.

I was going to try another experiment but it's gonna take me a couple of hours to set up. I was thinking about backing up my two working drives on a big-ass external firewire drive, and then try loading only Samp SE on a completely barebones XP with no other apps to see if anything else was interfering. A complete elimination of all other software variables... Not sure I want to go through the hassle though 'cause I'm afraid it's only going to end up with the same result.

I'm going to go have dinner and then decide whether I want to burn an evening doing this.

Thanks for sticking with me - glad to see a fellow Logic PC user around still (the dying breed).

Res

Link to comment
Share on other sites

I tried your piano roll experiment and it sort of works BUT now does what I was saying before only backwards! It starts out in time, and then drifts out by the end of the sequence by speeding up... Which I guess is exactly the same thing only starting in the right place and ending up in the wrong place instead of vice versa. Try it again on your system to make sure it's not still speeding up.

I don't seem to have the speeding up problem , just the offset problem when recording directly into the arrange page.

was going to try another experiment but it's gonna take me a couple of hours to set up. I was thinking about backing up my two working drives on a big-ass external firewire drive, and then try loading only Samp SE on a completely barebones XP with no other apps to see if anything else was interfering. A complete elimination of all other software variables... Not sure I want to go through the hassle though 'cause I'm afraid it's only going to end up with the same result.

I have a basic XP partition ghosted and I was tempted to try the same thing but I have a busy week so maybe next weekend . Also I'm hoping V9 will arrive soon so maybe a clean install would be a good idea anyway .

Thanks for sticking with me - glad to see a fellow Logic PC user around still (the dying breed).

Well I actually switched to Samp about 18 months ago and only use Logic now and then when collaborating with a drummer friend although I still have a soft spot for it.

BTW here's a little app thats you can use to check out your midi timing :TGTQPC.zip. Run it and make a note of the last figure when it's finished. Mine is 2.65393ms which is a relative error of about 0.00331276 (which I beleive is acceptable)

Regards

Kraznet

Link to comment
Share on other sites

Kraz, delta TGT-QPC: 135.392ms which is a relative error about % 0.681576

I've run the test a number of times and it varies each time - from 141ms to 121ms - either way it's still pretty bad, although I don't know what to make of the data exactly. Something about Samp either using the TGT or QPC to clock its MIDI engine??? (full of sh*t answer from me of course) Not sure what the issue is when every other app from freeware to pricy I've tested hasn't had this problem.

Of course if you're having MIDI issues as well (along with a number of other people I see) and your discrepancy is only 2.65ms then I think this is just dealing with where the MIDI notes are placed upon recording - how far front or back from the downbeat? (again another purely scientific hypothesis :wacko: )

I think I might wait for you to install V9 on a fresh XP and see how you get on. I'd appreciate it if you let me know what happens.

In the meantime I'll keep clutching my Logic 5.5 like grim death, 'cause most of my work is mainly MIDI based. ;)

Res

Link to comment
Share on other sites

This is a little disturbing to hear cause I've just order my copy last week. I think i had a similar problem with the demo but didn't think to much of it thinking it was a demo bug or i had done something wrong...basicaly i tough every daw did ok with midi. My falt i guess... I hope everything turns out ok cause i really tough i had a complet solution, and samp has such a good design. Please MAGIX, make sure this is looked at cause midi is escencial now, and Samplitude deserve it. ;)

With a bit luck i wont have this problem on my system :wacko: .

Link to comment
Share on other sites

Hi Res,

Kraz, delta TGT-QPC: 135.392ms which is a relative error about % 0.681576

That does seem a bit high but how it's related to your problems I'm not sure . Maybe it's time from Frank to chime in..

how far front or back from the downbeat? (again another purely scientific hypothesis

The test I've been doing is at 120bpm playing just a single note along with the click and the drift is between 1/16 and close to 1/8th forward in time .But as I said the leaving the midi editor method open seems to cure it for me .This is using the B4 VSTi with Asio. I tried another test which was suggested by Frank while back on the forum . That is to use the WDM driver ( hit Y System/Global Audio Options) then and play along with the click blind so as to speak without Asio monitoring and oddly enough when i do that the timing seems fine when recording in the Arrange so it must be Asio related . Maybe you could try that.

Cheers

Kraznet

Link to comment
Share on other sites

Resonance reported delta TGT-QPC: 135.392ms which is a relative error about % 0.681576

This is not the midi lag in ms for each note, but only the difference between two timers on your PC after 20 seconds.

It seems that lower values (below 10 ms or so) are measurement errors and not a real problem.

A larger value (above 100 ms) on the other hand doesn't mean you must have bad midi timing, but it seems that people with a midi timing problem also have higher values, but our data base is small yet.

Some midi drivers use one timer, some the other, the same is true for Audio drivers... So if you have audio/midi drivers which use a different timer and the timers are not in sync (usually they are, especially on ASUS boards), this might explain the midi timing problem.

But first, did you try the .ini rename thing?

Do you have a Dell Inspiron Laptop? Or which hardware do you use?

Can you switch off onboard sound of your motherboard (BIOS settings)?

Greetings,

Frank

Link to comment
Share on other sites

But first, did you try the .ini rename thing?

Hi Frank,

yeah, that was the first thing I tried - it seemed to be a cure for other users - unfortunately it was a no go.

Do you have a Dell Inspiron Laptop? Or which hardware do you use?

It's a desktop Athlon XP 2600+ / Asus A7N8X deluxe / Matrox G450 Dualhead graphics / ESI Pro Wami Rack 24 PCI and breakout box / 2GB of DDR-SDRAM / Windows XP service Pk 2 - all drivers are up to date - like I said, this thing is rock-solid (or at least it has been up until now).

Can you switch off onboard sound of your motherboard (BIOS settings)?

I disabled all on-board extras when I originally built the computer. On-board graphics/sound/midi/LAN - everything except the USB - the deluxe version of the MOBO was all I could get at the time although I would have preferred the regular stripped-down version of the A78NX - but I digress.

@Kraz, I actually tested the WDM drivers again last night - flying blind without VSTi monitoring and got the same result as having the piano roll open with the ASIO - MIDI starts on the downbeat and then slowly speeds up by the end of the sequence.

Res

Link to comment
Share on other sites

But as I said the leaving the midi editor method open seems to cure it for me

Kraznet, what do you mean by this? You just need to have the MIDI editor openend and the problem is gone?

I suggest another test scenario (if you have an external synth):

record Midi and Audio from an external synth at the same time and check if the MIDI aligns with the audio signal. You can easily measure any offset in ms or samples by switching the ruler unit to ms and set a range on the offset. The range tooltip then displays the length.

For an optimized performance the system performance should be changed to 'optimized for background tasks'.

BTW what seemed a cure for some users is switching the computer type from ACPI to Standard PC, especially with Windows 2000.

Be warned : This change is not reversable!!! - without a complete system re-install.

see

http://support.magix.net/boards/samplitude...ost&p=54162

Before you do this, try the other suggestions (but Resonance seem to have tried them all yet..).

Take care that there is no IRQ-sharing going on (see http://www.rme-audio.com/english/faq/rme_faq.htm, search for IRQ).

Maybe re-installing the midi drivers also helps. Before you do this, you need to clean them from the registry manually (some drivers may fill the registry with emulated DirectSound-MIDI drivers and therefore the MME versions might not be available...and Samplitude uses MIDI MME drivers).

http://www.rme-audio.com/english/faq/10entrye.htm

Greetings,

Frank

Link to comment
Share on other sites

BTW what seemed a cure for some users is switching the computer type from ACPI to Standard PC, especially with Windows 2000.

Be warned : This change is not reversable!!! - without a complete system re-install.

Yes. There is a good chance that with the A7N8X, changing to Standard PC will solve the "midi recording too fast" problem. Believe me, I tried everything else!!

I have a separate windows installation on a separate partition in which I've changed to Standard PC, just for when I need to record midi.

Cheers,

Simon.

Link to comment
Share on other sites

BTW what seemed a cure for some users is switching the computer type from ACPI to Standard PC, especially with Windows 2000.

Be warned : This change is not reversable!!! - without a complete system re-install.

Yes. There is a good chance that with the A7N8X, changing to Standard PC will solve the "midi recording too fast" problem. Believe me, I tried everything else!!

I have a separate windows installation on a separate partition in which I've changed to Standard PC, just for when I need to record midi.

Cheers,

Simon.

Simon that seems pretty drastic having to multi-boot just to record MIDI... I remember doing that sort of thing way back in the day but it's almost 2007... I'm gonna try it of course - just backing up my system as we speak (heh) - will give an update when I've finished and tested everything again.

Thanks for all the replies, people... believe me, they are greatly appreciated. :wacko:

back in a bit.

Res

Link to comment
Share on other sites

Alright, I'm back with the scoop.

This is really getting strange - I switched modes to Standard PC, pointed XP at all the drivers, rebooted, and everything looked good. Started up Samp, started recording MIDI and... the same thing. Arrggh.

The full quarter offset and speed up drifting is still there unless there is already a MIDI object (empty or not) present on the same (or) in another track.

With a MIDI Object present, Midi recording seems to work alright but it's definitely not tight. It plays back the recorded sequence like I'm pushing the beat slightly - yet I know when I recorded it I was laying slightly behind the beat. So it's better and possibly useable, but nothing like working with MIDI in other apps. I did a quick test in Logic 5.5 and it feels absolutely solid still. There's something going on in Samp with the MIDI thing.

So to recap:

ACPI = speed up drifting at all times, with or without a MIDI object already present. Accurate (to a degree) start time with MIDI Object present, but a full quarter note ahead without a MIDI object present.

Standard PC = speed up drifting only if no MIDI object is present. Accurate (to a degree) start time with MIDI object present, but a full quarter note ahead without a MIDI object present.

Comments? Questions?

I'm fairly certain I would love Samp if the MIDI was sorted (and there was an auto-quantize feature)...

Res

Link to comment
Share on other sites

Kraznet, what do you mean by this? You just need to have the MIDI editor openend and the problem is gone?

I suggest another test scenario (if you have an external synth):

record Midi and Audio from an external synth at the same time and check if the MIDI aligns with the audio signal. You can easily measure any offset in ms or samples by switching the ruler unit to ms and set a range on the offset. The range tooltip then displays the length.

Hi Frank yes thats right with the midi editor open the problem goes away. Also I tried your test . I hooked up the Audio out of my Korg Prophecy and recorded on one audio track and one midi track a single repeated note in time with the click at 120bpm and the midi is ahead of the recorded audio by about 6/7ms this is with the Asio buffer set to 1.5ms and the VIP buffer set to 2048 .Ok so I'd expect the Audio to be a little late .The Midi is recorded straight without a VSTi inserted .post-1463-1157397260_thumb.jpg

Next thing I did was insert a VSTi on the Midi Track (Lounge Lizard)and repeated the test . The midi was 192ms ahead of the recorded audio post-1463-1157397632_thumb.jpg

Then I opened the Piano roll and deleted the midi notes and recorded the Audio and Midi again and it was back down to 7ms again post-1463-1157397916_thumb.jpg

This proves to me that this problem only exists when recording with a VSTi is inserted but does not happen when the Piano Roll is open .

Regards

Kraznet

Link to comment
Share on other sites

ACPI = speed up drifting at all times, with or without a MIDI object already present. Accurate (to a degree) start time with MIDI Object present, but a full quarter note ahead without a MIDI object present.

Standard PC = speed up drifting only if no MIDI object is present. Accurate (to a degree) start time with MIDI object present, but a full quarter note ahead without a MIDI object present.

Comments? Questions?

Hi Res ,

I was out all day so I've only just had time do the test Frank suggested. Looks like we're getting somewhere and it's interesting that Standard PC seems to maek a slight difference but the speeding up thing is very odd as well as I have not noticed that . Are you using a VSTi when you do these tests ? As you will see from my post above when you just record midi with no VSTi inserted the timing seems alot better . Maybe you should try that and report back :wacko: .

Regards

Kraznet

Link to comment
Share on other sites

ACPI = speed up drifting at all times, with or without a MIDI object already present. Accurate (to a degree) start time with MIDI Object present, but a full quarter note ahead without a MIDI object present.

Standard PC = speed up drifting only if no MIDI object is present. Accurate (to a degree) start time with MIDI object present, but a full quarter note ahead without a MIDI object present.

Comments? Questions?

Hi Res ,

I was out all day so I've only just had time do the test Frank suggested. Looks like we're getting somewhere and it's interesting that Standard PC seems to maek a slight difference but the speeding up thing is very odd as well as I have not noticed that . Are you using a VSTi when you do these tests ? As you will see from my post above when you just record midi with no VSTi inserted the timing seems alot better . Maybe you should try that and report back B) .

Regards

Kraznet

Kraz, yeah, I've been using a VSTi to do these tests - FXPansion's DR-008 with a drumkit loaded... Recording without a VSTi is making things go flaky here. Yes the 1/4 note misplacement has gone, but I'm getting buildups of MIDI events in the buffer and then random notes and chords start triggering my Triton ProX (which is my keyboard controller)... Once I load a VSTi the problem of random triggering goes away...

Tis indeed an interesting thing.

Have you tried just putting a blank MIDI object on one of your tracks (without the piano roll open) and then recording a sequence? I find this works exactly the same as leaving the piano roll open... You can just leave a blank MIDI object anywhere in your arrange page and things improve...

Weird

Res

Link to comment
Share on other sites

Have you tried just putting a blank MIDI object on one of your tracks (without the piano roll open) and then recording a sequence? I find this works exactly the same as leaving the piano roll open... You can just leave a blank MIDI object anywhere in your arrange page and things improve...

Hi Res,

I haven't tried to the blank midi object but I will. At the moment I just made a small partition so I can install my original XP image and then see how things are. Just a thought when I did the MIDI test I only had the MIDI out connected which might account for why I wasn't getting buildup of MIDI notes. Or maybe your controller doesn't have on board sounds. I'm sure you thought of all these things anyway .

Regards

Kraznet

Link to comment
Share on other sites

So this is my last update for today. Made a small partition on my hard drive and installed an XP image I'd made during my last install .This is a minimal install with the only drivers for my RME Hammerfall card and the AMT8 for MIDI. Only other programs installed are Acronis True Image and Acronis Disc Director Suite. Windows XP professional service Pack 2 that's it. Installed Samplitude 8.11 from the original disk and installed Native instruments B4. Played a single note line along with metronome . Playback was fine with no offset.

Installed Samplitude 8.2 . Same again , record and playback fine with no MIDI offset. Installed Samplitude 8.31 MIDI was offset as reported before. Only problem is now opening the midi editor doesn't cure this. So at least it's consistent B) . I'm not quite sure what is going on maybe it's machine specific but it does seem odd that the problem only arose when I installed 8.31.

Regards

Kraznet

Link to comment
Share on other sites

Hm a lot of people had MIDI problems with AMT8.

If 8.2 and 8.1 work fine then it may be fixed for 8.3 by adding the Samp*.INI entry

[setup]

MidiInDontReopenDevices=1

Also make sure that VIP Buffers are a power of 2, e.g. 2048 instead of 2000.

Pick the "Advanced Buffer Settings..." ASIO/VSTi preset in the Y (System) Dialog.

Greetings,

Frank

Link to comment
Share on other sites

Hm a lot of people had MIDI problems with AMT8.

If 8.2 and 8.1 work fine then it may be fixed for 8.3 by adding the Samp*.INI entry

[setup]

MidiInDontReopenDevices=1

Also make sure that VIP Buffers are a power of 2, e.g. 2048 instead of 2000.

Pick the "Advanced Buffer Settings..." ASIO/VSTi preset in the Y (System) Dialog.

Greetings,

Frank

Frank, I'll add that to my setup_e.ini and see what affect it has...

Res

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...