Jump to content

Playback At Higher Pitch Using Alesis Io|2


Kenny
 Share

Recommended Posts

Hi,

I've only recently decided to attempt to get my piano (Yamaha Clavinova CVP-203) to play through my computer. Samplitude 8.3 SE looked a good bet and it works really nicely. I play my piano through the AUX OUT into the alesis io|2 which in turn connects to my PC through USB. All good so far. I can play stuff on the piano and it does indeed get recorded by the PC. However, when I play it back, it is at a higher pitch.

Now, at first I figured I had set something incorrectly but no, I couldn't find what. Much info on Elastic Audio is provided but I couldn't find anything which suggested how I could have managed to record the piano and tell Samplitude to raise the pitch by around three quarters of a tone. So, I put it down to the fact that I must have set something wrong somewhere, and decided to install the software on my laptop.

At first, total success - I record stuff from the piano and play it back and it is recorded at the same pitch. Then I must've done something, because it worked for all of 2 minutes and now it (the laptop) is now doing *exactly* the same thing that my desktop PC did - it is playing it back at around three quarters of a tone higher.

At this point I started screaming.

The only thing I can think that I did to make this happen was to change the output of the music to go through the alesis io|2 device so I could listen to it on headphones, at which point it started playing at the higher pitch. However, when I then change it back to play through my laptop speakers (which are clearly awful quality) it is *still* playing at the higher pitch.

I have no idea why it did this or how to reset it to playing at the pitch it was recorded at. I also have no real way of knowing whether it is the samplitude software that is at fault, or the alesis io|2 device or software, or indeed a combination of the two.

Can anyone offer any suggestions as to what I should do? I'm getting close to smashing the alesis io|2 device off a brick wall because I've spent 2 weeks attempting to determine what the problem is with virtually no success.

Link to comment
Share on other sites

Somewhat annoyingly, despite this problem happening for the past week, it has now gone away and I can't replicate it.

I shall go hide in a hole, sitting in the corner, and whimper. And, of course, pray it doesn't come back; or at least if it does, I shall attempt to figure out how to replicate it.

Link to comment
Share on other sites

Probably a 44,1 kHz vs 48 kHz Samplerate problem... Somehow the Alesis driver used another SR than Samplitude. Sometimes a driver reset sorts this out, e.g. by switching from ASIO to WDM and back to ASIO (assuming you are working with ASIO).

Greetings,

Frank

I concur... Sometimes I have the same issue with my M-Audio system. If I check the settings on the M-Audio control panel, I sometimes find the sampleerate set to "48" when the Samplitude session is set to 44.1. I also use an external digital clock. If I forget to reset it, I get the same issue. Hope this helps. B)

Check your Alesis control panel the next time this happens. You will probably find a samplerate mismatch.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...